Jands Lighting
It is currently Tue Jul 07, 2020 5:24 pm

Post new topic Reply to topic  [ 2 posts ] 
 CLI Interface Not Working Properly On MacOS 
Author Message

Joined: Sun Jul 01, 2018 6:07 am
Posts: 1
Reply with quote
Post CLI Interface Not Working Properly On MacOS
I help out at a church that uses a Jands Vista S1 control surface with a Mac Mini. We recently got an Elgato Stream Deck to see if we could get it to work with some of our equipment to do basic tasks. I was looking into if it would work with Jands Vista and my first thought that there was a command line interface that the stream deck could type into. I looked it up online and found all the commands the CLI could use and programmed them into the stream deck at home on a Windows PC. All of the commands worked fine and typing in the commands the usual way and that also worked as detailed here (http://kb.jands.com/291/). After programming the stream deck on the windows pc I went to try it out on the mac mini and S1 control surface. I had put the Stream Deck Profile and Jands Vista show file in Google Drive and downloaded them on the mac. I opened both programs up and connected the stream deck but when I tried to use it to access the command line it did not automatically start typing into the command line like it should when you press certain keys. I then tried clicking on the command line first and then using the Stream Deck. No matter what I did on the stream deck it would say Store All. Then I used the keyboard to type in the commands and that worked fine. Then I opened a text box and used the Stream Deck to type into it and it typed exactly what it should. I tried then restarting Jands Vista and nothing changed. I then restarted the computer and again nothing changed. Then I uploaded both the Stream Deck profile and the Jands Vista show to Google Drive so I could try them at home. I went home and downloaded them and they worked fine on my Windows PC. So I had narrowed it down to the CLI not working the way it should on MacOS. Both the Windows PC and the Mac were running Jands Vista Byron v2.3.15287 with library version 134. I know that it is not the latest version of Byron but we don't usual update programs unless we need to or we are sure that the will be stable. The Windows PC is running Windows 10 Home version 1803 build 17134.112 and I do not know about the Mac Mini. The only thing that I think could be happening is if the Stream Deck is using function keys to talk to MacOS and it is being confused with the console on the Mac Mini if the console uses function keys to communicate. But since the Windows PC doesnt have a console connected it isnt being confused there.

Sun Jul 01, 2018 6:31 am
Site Admin
Site Admin

Joined: Sat Aug 14, 2004 12:13 pm
Posts: 519
Location: Sydney, Australia
Reply with quote
Post Re: CLI Interface Not Working Properly On MacOS
Can you detail some to the commands or keystroke combinations you have programmed on the Elgato buttons?

If the Command Line shows 'Store All' it indicates that the Elgato has sent the character 'A'

Tue Jul 03, 2018 4:20 pm
Profile WWW
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 17 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © phpBB Group.